Staked balance changed to nothing

Can anyone here point in the right direction maybe? I was staking a decent amount on , all was well until this morning when I logged in and the staked amount and balance was suddenly zero… :frowning:

1 Like

Tried three different systems. Link wallet, no balance or staked balance, and NO VOTING history or proposals. Yesterday I clearly remember there being one proposal open that I had already voted for. If anyone has any idea what kind of sync issue might be going on, please, hit me up.

Sounds odd. What wallet are you using? Try reconnecting metamask or logging out and back in again.

Coinbase Wallet (not I connected my Metamask and now I can see the votes. Connected back to original wallet. Still no balance. This is when I staked it, you can verify I never moved the funds since then:

I’m experiencing the same issue as well. Staked from my Coinbase Wallet 3 days ago. It showed the correct staked balance even yesterday, but now it shows zero. I hope it’s just a sync issue… Anyone else experiencing the same issue?

1 Like

Thanks for the Reply! I hate to say I am happy to see someone else have the same issue, but it gives me some hope this will get resolved!!!

Same here, using Ledger. Also no voting history or proposals. Would be nice if someone from the team responded in this thread.

1 Like

For sure, I hope they do!

Guys help me spread the word please:

Have you tried checking your balance directly from the contract using etherscan?

1 Like

Not sure if thats what you are asking, but thats when I started the contract/staking.

Also tried to refresh using Ctrl + F5 .

Go to

in 2. balanceOf paste in your ethereum address.


[ balanceOf method Response ]
uint256 : 374300000000000000

It’s seemingly a connectivity issue with Coinbase Wallet - I faced the same issue when I first staked a couple weeks back.

Just import your Coinbase Wallet into a new Metamask wallet using your seed phrase. I access it via Metamask now with no issues.


Thank you! This works!

I was worried about this too, I also cannot access my staked yfl. It looks like this is the issue:

It is related to Infura - Rate Limits

What should I do if rate limited?

The easiest solution is to pause JSONRPC activity for the amount of time returned in "backoff_seconds" .

What factors does Infura use to determine rate limits?

Rate limiting will be applied account wide after the accounts daily request limit is exceeded.


Hi, I am having the same issue. How exactly did you solve this?

How to check your $YFi ygov balance directly in Etherscan.



I simply used Metamask to connect. You can import your seeds in Metamask and voila, you can use Metamask to connect instead.

1 Like