Anyone else having the zero staking balance issue after depositing and staking YFI?

Hi, I have deposited 1 YFI 3 days ago and staked it, and voted for three proposals. After 1 day I do not see my staking balance anymore and also, I see no old/new proposals. I am using Ledger and Chrome. In Etherscan I can see my YFI balance but I cannot unstake anymore in ygov-finance. Can anybody help please me, possibly one of the devs?

Are you using Metamask in Chrome? That works best. Also you can check your wallet on Zapper to confirm what you have staked.

Also the voting interface is not working properly, a lot of people are having issues with that. But the staking totals should be working.

1 Like

This might be an infura issue. It is known and being worked on, should be fixed soon.

1 Like

Thanks a lot for the quick answer! I have tried to connect with Metamask (using Ledger to connect to Metamask) and then the balance shows! It must be some Ledger problem I guess.

Thanks! I have tried Metamask and now I can see my balance! I guess it is some kind of Ledger problem.

You can unstake and collect rewards directly all in one go using Etherscan.



Excellent work around, thank you! I have switched to using Metamask and this already worked for me๐Ÿ˜„

1 Like