How to claim rewards from

The claim reward button is disbaled. Anyone has similar issue ?
I un staked before claiming the reward, is that the the root cause ?
Post this again staked $YFI, still claim reward button is disabled.

1 Like

I think you need to have voted recently to claim

1 Like

YIP: Release fee rewards : Did this YIP not remove the need to vote before claiming the reward ?

1 Like

It did, you just need to claim from the contract directly until the UI is updated

1 Like

Oh yes, I forgot about that. How long since that was approved?
DigitalKarma, you can do simple interactions with the contract via Etherscan. Are you confortable with that? I dont know how long until the UI is updated

Can you provide me the procedure ?

Honestly no, I dont feel comfortable directing you there unless you already know what you’re doing.
Since it seems you don’t have much experience interacting directly with smart contracts I recommend you just wait for the update.
But if you want to go on an adventure and try figuring it out, that’s up to you.

Normally I would agree with Bob, but this is a simple interaction and mostly harmless. I rather you get it from here than from other guide in the internet

First of all, do not trust anyone, do not trust me: Verify.
If you feel uncomfortable with any of the steps stop.
Share this info in the Yearn support discord and/or wait for further answers to this thread.

How to reach the contract
1.- In the yearns staking page, you can see the contract address:
If you click on it you will be redirect you to etherscan. an ETH block explorer.
Also, if you recall when more or less you staked, you can check on your outgoing transactions in the ‘To’ column, you should see Staking

2.- Checks.

  • Check that Etherscan is indeed etherscan xD. https and all that.
  • Check that the contract is itself the contract.
  • Is the begining and end the same as in the ygov page? 0xBa37…D992
  • Contract overview info.
  • Is the contract creator the yearn deployer?

3.- getReward
Go to Contract
Write Contract
Connect Metamask

Method 3 is getReward
Click Write and Metamask will be prompted.

4.- Metamask checks
Confirm with whom are you interacting → 0xBa37…D992

What method are you calling → Get Reward

Enjoy your first manual interaction with a smart contract!



Thanks money in my wallet thanks for the very clear instruction .

1 Like

I had about $9 of rewards and so I wanted to try this out. I ran through the entire process and it was successful but the transfered value is $0.00. Gas fee was $2.70. Why is that? What crypto is supposedly transfered?

Check the dashboard at does it still show your rewards? Also you can dm me for more help or join telegram and I can help you there.

When I click Get Reward" I get a message saying to “Please Connect to your web3 provider” Not sure why I am getting this.

Check ERC-20 token transfers. Maybe the transfer was 0 eth but ERC-20 tokens

I checked but did not see my transaction. I still get the same error message to connect to my Web3 provider despite my metamask is connected.

I ran it again and success! Props to @Froyo for the tutorial and introduction to this newbie! It is greatly appreciated!


Anyone know how to claim rewards not manually. I can’t seem to get my CBW to Metamask and therefore can’t follow this tutorial. It won’t allow me to claim rewards even though I have voted. Any idea if it will allow me to claim rewards soon?

To claim rewards, you can either use our backup UI ( or you can interact with the contract directly ( and call getReward

also, in the future, if you have questions, it’s best to head to our discord and get support there.