Anyone else not able to claim YFI staking rewards in ygov?

I’ve voted multiple times both in V1 and V2 gov. I’ve even re-read

and followed the flowchart with my :pinching_hand: :eyes:

But I cannot click the button that says “claim rewards”.

Anyone else have this issue?


when did you vote? It locks you for 3 days.

Same, voted on multiple YIPs (latest were 35 and 36) and rewards are not claimable, it’s not much I don’t mind, but I wouldn’t want there to be an underlying issue.


FWIW several other users brought this issue up already

1 Like

What is the magnitude of the rewards expect for staking YFI/voting per YFI ?

Magnitude so far is not high; but if YIP 37 passes, the rewards could increase quite a bit.

Anyone have this issue and found a resolution?

I’ve voted multiple times, most recently in YIP 37 about 36 hours ago.

But I’m not trying to unstake my YFI. I’m just trying to use the button that says “claim rewards”.

I’ve unstaked my YFI before to participate in YAM, but even after unstaking and now restaking, my rewards are still locked.

1 Like

I’ve recently voted as well and the button to claim is locked.

Yep. Same issue for me. I have voted on every YIP to date, never unstaked.

Same problem. Voted multiple times. rewards, have awards, but unable to claim them.
Also, v2 voting does recognise me as “voted”, allowing me to vote multiple times

1 Like

I also have the same issue

1 Like

Rewards cannot currently be claimed, as they are being funneled into the treasury– as per YIP 36 ( You can check how much the treasury is currently holding here ( and how close we are to the $500k.


Thanks. Will wait till 500k and check again.

However, I’ve had this this issue from way back, way before #36 was even conceived. Since around when the lock was first introduced.

1 Like

So I know that the voting multiple times things is a bug, but it only counts the vote once. I’m not as sure about lack of rewards– I wasn’t around pre-YIP 36

This explains a lot and should be added to the page where we claim!

Good to see that i’m not the only one with this problem but can you guys unstake ? i can’t even unstake and the gas price to unstake is huuuuge (1.3 eth) but even if i accept the transaction eventually fails i’ve tried lower the gas fee i’ve tried everything. Transaction keeps failing.

if you voted you can’t unstake for 3 days. It shows that you can for that high gas price, but it will always fail.

you’ve tried multiple times? Including once spending 1.3 eth? i feel for you bro :frowning:

it luckily didn’t spend the 1.3 eth and yeah found it in the blog posts somewhere. Hard to find that information. Did spend like 30 dollars in gas fees on failed transactions and was getting a bit frustrated but at least now i know :smiley:

Hey, thanks for the info. I’m new here too, but trying to navigate through it.

Good to read the thread, I was wondering the same thing.

1 Like