Unable to withdraw unbonded kp3r

I have the button that shows I’m able to withdraw my unbonded kp3r, but it doesn’t allow me to withdraw it. I’ve unbonded the funds two weeks ago so I should be able to withdraw it. Am I missing something? Thanks.

1 Like

Same issue. I waited 14 days, unbonded, and they are still pending unbonding and the 14 days reset again.


I think this will fix it: fix withdraw from calling bond again by listonjesse · Pull Request #22 · keep3r-network/keep3r.governance (github.com)

The withdraw button was calling bond for some reason and also was trying to provide a withdraw amount when the keeper abi only allows withdraw all


Ive heard of others experiencing a similar issue with un-bonding. After the un-bonding period, no Kp3r were returned, and instead a new un-bonding period began. This is all within the keep3r v1 network website and not open zeppelin or other means.

Any advice would be helpful, thanks.

I’m having the same issue. My bond was activated on 11/1/2020 and I should be able to unbond/withdraw by now. When I click the unbond button, nothing happens. Any help would be appreciated, thanks.

Yes still no Kp3r show up in my wallet. Worried I lost my tokens.

am also unable to withdraw the kp3r after 14days of waiting

Hi all, I think antonnell took in my withdraw fix. Can you refresh the website and try again? Your coins should be safe


Is it normal to see $500 fee for unbounding 1 kp3r?


the tokens are there - but we are not able to withdraw to our wallet - when we select the kp3r to withdraw it is always 0 but as you can see unbond pending is shown

@andre.cronje can provide insight here and help us get back the kp3r - unbonds pending is shown but when we click withdraw it doesnt select the kp3r and it always shows 0 in contract

Are you sure you didn’t unbond already? $500 fee means a tx error

can you show a new screenshot of the webpage? There were some withdraw updates, but I am unsure if they are live yet

see attachment

For this, can you try just unbonding 1.0393 or something a little big smaller than the number currently in the text box?

yea here is the new page after clearing data and cache - you can see if i try to select kp3r which is unbonds pending it always shows 0

That’s interesting. My fix was accepted in the repo, but the website was not updated yet with the change.

If you are willing to trust me, you can withdraw using the smart contract directly on etherscan.

  1. go here Keep3r: KP3R Token | Address 0x1cEB5cB57C4D4E2b2433641b95Dd330A33185A44 | Etherscan
  2. connect to web3
  3. scroll down to the withdraw function (number 37)
  4. put in the KP3R token address 0x1cEB5cB57C4D4E2b2433641b95Dd330A33185A44 for the bonding parameter. This means you are withdrawing your KP3R bond. If you had a bond in a different token like WETH or something, then you would use a different address here.
  5. hit write and accept the tx

wow received them thanks bro <3

1 Like

Wow thank you!!! Can confirm worked for me as well.